problem to upgrade grails app from version 1.0.3 to 1.3.3

pankajsharma

New member
Hi,
I have to upgrade my app from version 1.0.3 to 1.3.3.First Is it possible to upgrade it.Initially I tried to upgrade it on lower version which is 1.2.1 using clean and upgrade command.I got success but when I tried to upgrade it on 1.2.2 it is giving error

java.lang.NoClassDefFoundError: org/codehaus/groovy/tools/RootLoader
Caused by: java.lang.ClassNotFoundException: org.codehaus.groovy.tools.RootLoader
at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
Could not find the main class: org.codehaus.groovy.grails.cli.support.GrailsStarter. Program will exit.
Exception in thread "main"

If it is possible to upgrade it ,what step will be used.
Please help me out.
Pankaj
 

dave

Administrator
Staff member
I would double check you have the correct version of Groovy available for Grails 1.3.x

Are you performing the upgrade via command line or using IDE tools?
 
Top